Midlife Crisis: Support for Left Behind Spouses

Midlife Crisis => Our Community => Topic started by: UrsaMajor on February 18, 2020, 06:37:46 AM

Title: RE: Forum Problems 3
Post by: UrsaMajor on February 18, 2020, 06:37:46 AM
New Thread for Forum Issues

Previous Thread: https://mlcforum.theherosspouse.com/index.php?topic=10341.msg757828 (https://mlcforum.theherosspouse.com/index.php?topic=10341.msg757828)
Title: Re: RE: Forum Problems 3
Post by: UrsaMajor on February 19, 2020, 11:34:00 PM
I've blocked msnbot, had logged 50k database errors in past 3 days.  Ignored robots.txt, 600 errors in 8 minutes, so blocked it in .htaccess.  Forum is running faster for a change, will see how long it lasts.

So, it seems that you found one of the culprits....
Title: Re: RE: Forum Problems 3
Post by: UrsaMajor on February 21, 2020, 04:30:57 AM
I've blocked msnbot, had logged 50k database errors in past 3 days.  Ignored robots.txt, 600 errors in 8 minutes, so blocked it in .htaccess.  Forum is running faster for a change, will see how long it lasts.

So, it seems that you found one of the culprits....

There haven't been any new database errors since you blocked msnbot so that was hitting us hard....
Title: Re: RE: Forum Problems 3
Post by: Sir Osis on February 21, 2020, 09:36:22 AM
Still getting some odd error bursts, but running a lot cleaner overall.  Is the forum running faster for you?
Title: Re: Forum Problems 3
Post by: Rollercoasterider on February 21, 2020, 10:45:56 AM
Okay, so Sir Osis has recommended I switch hosts. I've just finished chatting with a new host and will bring what was said to Sir Osis.
One of the concernes might be those high numbers. No, 600 is not really a lot relatively speaking, but it's been the norm for the past few weeks/months and before that it was completely abnormal--as I can recall.
I started posting at the blog again, but the traffic so far has not really gone up yet and so it doesn't make sense to me that we would suddenly have an influx of new traffic when I have not done enough to drive it here yet.
The downtime with a host switch should be none to very little.
Title: Re: RE: Forum Problems 3
Post by: Rollercoasterider on February 22, 2020, 11:31:52 AM
The post below is a copy of a global PM I sent to everyone about 2 minutes ago.

We are about to migrate the forum and blog to a new host. In order to begin this process, the forum and blog will be temporarily in maintenance mode and you will be unable to have access. I am not sure how long the down time will be, but hope it will be minimal.
The time is now 11:30 am Pacific Standard Time
I will enable maintenance mode in 20 minutes...to give those of you who actually read this time to finish any posts.

We should have a faster forum after this move and will be able to complete the upgrades and eventually a new--mobile responsive theme--once we are at the new host.

Sorry for any inconvenience,
Kenda-Ruth

Title: Re: RE: Forum Problems 3
Post by: Sir Osis on February 22, 2020, 02:24:38 PM
Forum is now running on new server (it's hot :) ).  DNS update may still be propagating, but if you're here and we're not in maintenance mode you're at new host.  Any feedback will be helpful.
Title: Re: RE: Forum Problems 3
Post by: AlvinTheMaker on February 22, 2020, 10:23:29 PM
Loads VERY quickly, almost instantly....  :)

Great job (I assume you switched from some shared plan to some VPS/dedicated server?)

Alvin.
Title: Re: RE: Forum Problems 3
Post by: Sir Osis on February 23, 2020, 07:13:37 PM
No, we're on a shared server with a very good host.
Title: Re: RE: Forum Problems 3
Post by: OldPilot on February 24, 2020, 09:56:42 AM
No, we're on a shared server with a very good host.


:) :) :) YAY!   

THANKS
Title: Re: RE: Forum Problems 3
Post by: TDurden on February 24, 2020, 12:33:44 PM
Hello, I have tried to post in my own thread and keep getting 403 Forbidden.  I have logged out and back in.  I will try again at home in case it's an IP thing.  Not sure if this will even post......

How about that, weird.
Title: Re: RE: Forum Problems 3
Post by: Thunder on February 24, 2020, 12:43:22 PM
I have been unable to get on the site since the 22nd, and when I could I could not access much of anything like a Guest, let alone reply, but late this morning I got on and things look normal.

I'm hoping it stays that way.

I just wonder if there are others who had that problem and still cannot access HS.  I hope not.
Title: Re: RE: Forum Problems 3
Post by: Rollercoasterider on February 24, 2020, 02:40:49 PM
I have been unable to get on the site since the 22nd, and when I could I could not access much of anything like a Guest, let alone reply, but late this morning I got on and things look normal.

I'm hoping it stays that way.

I just wonder if there are others who had that problem and still cannot access HS.  I hope not.
Given that there seem to be very few posts, I do wonder if others are continuing to have access issues.
If you can read this, but cannot post, can you let me know by submitting to the Ask a Question (https://www.midlifecrisismarriageadvocate.com/ask-a-question.html) page?
Title: Re: RE: Forum Problems 3
Post by: Sir Osis on February 24, 2020, 06:05:56 PM
Disabled modsecurity on all domains, it's known to cause problems for SMF.  I've been able to post since migration was completed using vpn, it's not blocking me.  Have asked Croc support if they see anything on their end.
Title: Re: RE: Forum Problems 3
Post by: Sir Osis on February 24, 2020, 06:22:49 PM
I do see 3 IPs that had the 403 error. There can be false positives when using modsecurity with a forum. You can try a few days without modsecurity and see if you still get the 403 error.

Regards,
CrocWeb Support Department

Title: Re: RE: Forum Problems 3
Post by: TDurden on February 24, 2020, 06:30:42 PM
Posted fine from at home.  Thanks.
Title: Re: RE: Forum Problems 3
Post by: Sir Osis on February 24, 2020, 06:39:47 PM
Try it from the ip that was blocked when you get a chance, should work now.
Title: Re: RE: Forum Problems 3
Post by: Rollercoasterider on February 24, 2020, 08:26:05 PM
Someone is trying to register, but cannot see the blocks of the verification form.
I've only heard from one person, but there could be others.
Title: Re: RE: Forum Problems 3
Post by: Sir Osis on February 24, 2020, 08:51:38 PM
Don't think I added that feature to Curve Multi Color, just on the new theme on clone.  Hold on, will do it now.
Title: Re: RE: Forum Problems 3
Post by: Sir Osis on February 24, 2020, 09:33:56 PM
Should be working now.  Cleantalk blocked my vpn, otherwise reg would have been successful.  Didn't make any changes to production forum other than to clean up errors.  You were seeing color block registration on clone on my server. 

Title: RE: Forum Problems 3
Post by: Nevertoomuch85 on June 07, 2020, 01:51:02 PM
Links to reconciliation stories not working. It repeatedly says I need to log in even though I'm logged in.
The same thing happens when I do a member search and click on their story
Title: Re: RE: Forum Problems 3
Post by: Sir Osis on June 07, 2020, 03:35:04 PM
Any idea when this started, or when any of the links last worked?

Ok, links should be working now.



Title: RE: Forum Problems 3
Post by: Nevertoomuch85 on June 07, 2020, 04:37:32 PM
I've noticed it for about a month, but it is indeed working now. Thank you for the speedy fix!
Title: Re: RE: Forum Problems 3
Post by: Sir Osis on July 11, 2020, 04:16:26 PM
There's been a problem in recent weeks with IE11 users not being able to access https sites on Crocweb servers, including this forum.  Don't know if anyone's reported that here, but they would have had to use a different browser to post a complaint.  Anyway, Crocweb support tracked the problem to a recent cpanel update that changed TLS support.  They made an adjustment on their servers and IE can once again connect to MLC.  Hope everyone here is well.